CCR1016-12S-1S+のSFPについて

こんばんわ

とうとうRouterboard CCRシリーズを買ってしまいました。。。
全ポートSFPです。

system routerboard print
       routerboard: yes
             model: CCR 1016-12S-1S+
     serial-number: *******
     firmware-type: tilegx
  factory-firmware: 3.33
  current-firmware: 6.41.1
  upgrade-firmware: 6.41.1

しかーーーーし
SFPがうまく初期化されてないっぽい。。。

ぼくが買ったのは
MCAFEE MT9103

コンパチリストをみると。。。。ないですw
https://wiki.mikrotik.com/wiki/MikroTik_SFP_module_compatibility_table

@RBUG_JPさん
ありがとうございます!!!

SFPは認識はしているのですが、
一度抜き差しするか、無効・有効してあげないと通信ができない状況です。

[admin@MikroTik] > interface ethernet monitor sfp1
                      name: sfp1
                    status: link-ok
          auto-negotiation: disabled
                      rate: 1Gbps
               full-duplex: yes
           tx-flow-control: no
           rx-flow-control: no
        sfp-module-present: yes
               sfp-rx-loss: no
              sfp-tx-fault: no
                  sfp-type: SFP-or-SFP+
        sfp-connector-type: RJ45
    sfp-link-length-copper: 100m
           sfp-vendor-name: McAfee
    sfp-vendor-part-number: SFP-T
         sfp-vendor-serial: ********
    sfp-manufacturing-date: 09-10-12
  sfp-dwdm-channel-spacing: 1Ghz
           eeprom-checksum: good

普通に認識はしています。
あと重要なのは、auto-negotiationは無効にしないとリンクアップすらしないのでご注意を

ということで起動時に
無効・有効にしてあげれば良いので以下のようなスクリプトを仕込みます。

https://wiki.mikrotik.com/wiki/Manual:Scripting

1)スクリプトの作成
GUIからだと

Policy・・・write

Source
:delay 5
:for i from=1 to=12 do={ /interface ethernet disable "sfp$i"}
:delay 5
:for i from=1 to=12 do={ /interface ethernet enable "sfp$i"}

こんな感じ
最初のdelayは、起動直後にはSFP自体を認識できないことがあるので遅らせています。

CUIだと

[admin@MikroTik] /system script
add name=script1 owner=admin policy=read,write source=":delay 5\r\
    \n:for i from=1 to=12 do={ /interface ethernet disable \"sfp\$i\"}\r\
    \n:delay 5\r\
    \n:for i from=1 to=12 do={ /interface ethernet enable \"sfp\$i\"}"

こんな感じ
ポリシーはwriteだけで良いです。

2)スクリプトをスケジュールに追加
GUIからだと

Start Time・・・Startup
Policy・・・write

On Event
script1

CUIだと

[admin@MikroTik] > /system scheduler
add name=schedule1 on-event=script1 policy=read,write start-time=startup

こんな感じ

スケジュールにそのままスクリプトを突っ込んでも動くと思います。

本国のサポートには伝えてあるので、
直るといいな〜

コメントを残す

メールアドレスが公開されることはありません。

Enter code * Time limit is exhausted. Please reload CAPTCHA.

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください